Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 19, 2026 - 13:00 CET
Scheduled
We are doing additional maintenance for a couple of our extramural care organizations. There is no expected impact on the functionality of our systems. Organizations that are affected by this maintenance are informed specifically.
Posted Feb 18, 2026 - 13:25 CET
This scheduled maintenance affected: Sensara API and Sensara Login.